Linux-Boi für SAMPHP-PlugIn-Kompilierung gesucht

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

Es gibt Neuigkeiten! Ab sofort könnt ihr dem Donators Club auf Lebenszeit beitreten.
Weitere Infos im Thema Donator's Club ab heute wieder verfügbar!

  • Linux-Boi für SAMPHP-PlugIn-Kompilierung gesucht

    Hi,
    ich suche jemanden der in der Lage ist (ich nix Linux :S ) das "SAMPHP"-PlugIn von Lapayo auf PHP-Version 7.3 zu kompilieren (sofern das vom PlugIn möglich ist).

    Folgendes Plugin:
    github.com/Lapayo/SAMPHP

    Ich habe einen Gamemode darin vor knapp 2 1/2 Jahren geschrieben, seither liegt der rum. Er ist auf einem fortgeschrittenen Stand - würde zur "Weiterentwicklung" gerne auf PHP 7.3 switchen.

    Folgendes wird beschrieben (siehe GitHub):

    Lapayo schrieb:

    1. You need: libxml2-dev, gcc, g++ (x86 environment!)
    2. Clone the repository.
    3. Run ./install_libphp5.sh as root, this will install php headers and libphp5.so
    4. Install SAMPGDK (github.com/Zeex/sampgdk#linux)
    5. run ./build.sh and copy the created samphp file to your plugins folder



    Ich habe mich bis zu Punkt 4 durchgehangelt, habe das ./install_libphp5.sh-Script entsprechend angepasst und PHP 7.3 geladen und "installiert", dann scheitert es aber an der Installation der "SAMP SDK", die eine Abhängigkeit der "SAMP GDK" ist.
    Ist einfach nicht meine Welt.

    Ich würde dafür bei Erfolg mich gerne auch via PayPal (o.ä.) erkenntlich zeigen. :)

    Man kann mich auch gerne anleiten - deshalb ist's nicht direkt im Marktplatz. :)

    @Beavis: hilf mir, es wird GTA:WC v2 (3. Versuch) 8o

    Dieser Beitrag wurde bereits 2 mal editiert, zuletzt von TutNichts ()

  • TutNichts schrieb:

    Ich habe mich bis zu Punkt 4 durchgehangelt, habe das ./install_libphp5.sh-Script entsprechend angepasst und PHP 7.3 geladen und "installiert", dann scheitert es aber an der Installation der "SAMP SDK", die eine Abhängigkeit der "SAMP GDK" ist.
    @GamerXiOS Wie gesagt, bei Schritt 4 hört's dann auf. Da gibt es nicht mehr viel zu erklären, außer dass ich da nicht durchblicke und nicht weiß, wie ich die zu installieren habe.
  • Gemeint war eher Kush der vielleicht eine Lösung parat hat - diese sollte im besten Fall doch mit allen geteilt werden

    /edit: also ich habs auch mal probiert auf Ubuntu 18.04, bleibe jedoch auch bei Schritt 3 hängen, alle nötigen Module sind soweit aber installiert
    Bilder
    • Bildschirmfoto 2018-12-29 um 14.06.37.jpg

      594,4 kB, 2.880×1.800, 19 mal angesehen
    „Nicht das, was du nicht weißt, bringt dich in Schwierigkeiten, sondern dass, was du sicher zu wissen glaubst, obwohl es gar nicht wahr ist.“
    Mark Twain

    ---
    ICH BIN NUR HIER UM LEUTE ANZUSCHREIEN
  • seegras schrieb:

    Gemeint war eher Kush der vielleicht eine Lösung parat hat - diese sollte im besten Fall doch mit allen geteilt werden

    /edit: also ich habs auch mal probiert auf Ubuntu 18.04, bleibe jedoch auch bei Schritt 3 hängen, alle nötigen Module sind soweit aber installiert
    Danke fürs Ausprobieren! :)

    Achtung, könnte kein guter Tipp sein: bei mir hakte es bei Schritt 3 auch ein wenig... als ich dann aber mit sudo make und sudo make install bzw. sudo ./configure arbeitete, ging es durch. Aber das war auch wirklich mein geballtes Linux-Wissen. :rolleyes: :D