Textdraw Editor Aufsetzung läuft schief

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

  • Textdraw Editor Aufsetzung läuft schief

    Hallo allerseits,

    mir treten leider Probleme auf beim Aufsetzen des Nickk's TextDraw Editor's

    Da ich gerne auf meinem vServer textdrawen möchte, bleibt mir nichts anderes übrig als hier zu fragen.

    Die Situation ist momentan, dass mein SA:MP Server beim Einsatz des Filterscriptes direkt crasht.

    Ich habe auch versucht crashtdetect zu laden, das Laden schlug hier jedoch fehl.

    Die einzige Server Log Meldungen, die ich bekommen habe sind folgende:


    Quellcode

    1. SA-MP Dedicated Server
    2. ----------------------
    3. v0.3.7-R2, (C)2005-2015 SA-MP Team
    4. [17:01:02]
    5. [17:01:02] Server Plugins
    6. [17:01:02] --------------
    7. [17:01:02] Loading plugin: crashdetect.so
    8. [17:01:02] Failed (/usr/lib32/libstdc++.so.6: version `CXXABI_1.3.9' not found (required by plugins/crashdetect.so))
    9. [17:01:02] Loaded 0 plugins.
    10. [17:01:02]
    11. [17:01:02] Filterscripts
    12. [17:01:02] ---------------
    13. [17:01:02] Loading filterscript 'ntd.amx'...
    14. [17:01:02]
    15. [NTD PL]Edytor TextDrawow od Nickk888 v4.45 Beta zostal pomyslnie zinicjalizowany!
    16. [17:01:02] [NTD ENG]The TextDraw editor from Nickk888 v4.45 Beta has been successfully initialized!
    Alles anzeigen
    PS: Ich habe kein Zugang zum Filterscript "ntd.amx"

    Wäre schön, falls mir da jemand eine Lösung vorgeben könnte.
  • Xazor schrieb:

    Die Situation ist momentan, dass mein SA:MP Server beim Einsatz des Filterscriptes direkt crasht.

    Ich habe auch versucht crashtdetect zu laden, das Laden schlug hier jedoch fehl.
    Folgender Fehler treten auf:

    Zum Einen der Crash, zum zweiten das Laden von crashdetect.




    Xazor schrieb:

    Failed (/usr/lib32/libstdc++.so.6: version `CXXABI_1.3.9' not found (required by plugins/crashdetect.so))
  • Wieso sollst du denn kein Zugang zur AMX haben ?
    Da ich glaube das es dieses Plugin nur für Win gibt, dass du auch einen Win32 SAMP Server hast.
    Daher klatscht du einfach das Plugin rein in der cfg (kannst bei win auch ohne die endung .dll schreiben, ist nur bei Linux relevant(.so) ) und lädst das FS entweder direkt in der Serverkonfiguration, via Konsole oder Ingame per RCON Kommando.
    Попытка - не пытка :rolleyes:

  • Kasakow schrieb:

    Wer hilfe will, ist lieber bisschen freundlicher.
    Bringt hier mal wieder nichts zum Thema bei.
    Nur folgendes lese mal lieber, anstatt unnötige Fragen zu stellen.
    Nichts für ungut, aber ich habe nur auf ein Zitat hingewiesen.


    Kasakow schrieb:

    Wie gesagt, sobald ich weis gibt es das Plugin nicht für Linux!
    Welches Plugin? Crashtdetect?
    Crashtdetect gibt es sowohl für Windows und Linux.

    Vom Textdraw Editor gibt es keine Plugins, ich kann aber den Vorschlag das Filterscript per RCON zu laden mal versuchen.
  • Leider bin ich in der ganzen samp Thematik nicht mehr wirklich drinn.
    Allerdings kann man anhand deiner Fehlermeldung

    Quellcode

    1. Failed (/usr/lib32/libstdc++.so.6: version `CXXABI_1.3.9' not found (required by plugins/crashdetect.so))
    erkenne, dass es sich hierbei nicht um ein Problem von crashdetect selbst, sondern um ein Problem der GCC Bibliothek handelt, welches auch häufiger
    in anderen Bereichen auftritt. Leider kann ich dir kein explizites Workaround für dein Problem bieten, allerdings half es schon einigen - wie hier zu sehen,
    einfach mal eine andere Version der Bibliothek zu installieren bzw. sogar nur auf eine andere Version zu verweisen.

    Ansonsten, da du ja ohnehin vor hast zu upgraden wäre natürlich die einfachste Möglichkeit einfach den Server mal neu aufzusetzen.
    Mit freundlichen Grüßen

    Headscracher | Tobi :thumbsup: