WBB_Connect 3.0 - Verbinde Server mit Forum

  • Kann ich mal wissen wie die funktionen nun jetzt heissen und wie die ersetzen soll ?


    (76751) : error 017: undefined symbol "WBB_IsValidUser"
    (76765) : error 035: argument type mismatch (argument 1)
    (76786) : error 017: undefined symbol "WBB_IsValidUser"
    (87833) : error 017: undefined symbol "WBB_EnableUser"
    (87867) : error 017: undefined symbol "WBB_AddUser"
    (87929) : error 017: undefined symbol "WBB_SetUserToGroup"

    Why do programmers always mix up Halloween and Christmas?
    Oct 31 == Dec 25

  • TPO : WBB_IsValidUser kann nun durch WBB_GetUserName ersetzt werden.


    Edit: Ich meinte natürlich WBB_GetUserID

    PAWNit gratis nutzen?
    Geschenkcode: 2017VQXPKB8V3KA

    Hier könnte Ihre Werbung stehen.

    Einmal editiert, zuletzt von |-|auke ()

  • Zitat

    TPO : WBB_IsValidUser kann nun durch WBB_GetUserName ersetzt werden.

    Danke für die schnelle Antwort, ich bekomme aber diese fehler hier
    (76751) : error 035: argument type mismatch (argument 1)
    (76765) : error 035: argument type mismatch (argument 1)


    Hier die jeweilige Zeilen
    (76751)


    WBB_GetUserName(inputtext,playerid);


    und


    (76765)
    WBB_CheckUserPassword(ForumsName,inputtext,playerid);


    Und wollte noch wissen welche ich mit den ersetzen soll ?



    (87833) : error 017: undefined symbol "WBB_EnableUser"
    (87867) : error 017: undefined symbol "WBB_AddUser"
    (87929) : error 017: undefined symbol "WBB_SetUserToGroup"

    Why do programmers always mix up Halloween and Christmas?
    Oct 31 == Dec 25

  • WBB_GetUserName erwartet nur einen Parameter. Dieser ist die Benutzer ID im Forum.


    WBB_GetUserID ist die richtige Funktion um WBB_IsValidUser zu ersetzten. - Ich habe mich eben verschrieben.


    WBB_CheckUserPassword erwartet die Benutzer ID im Forum und das Passwort. Die ID findest du mit WBB_GetUserID heraus.

    PAWNit gratis nutzen?
    Geschenkcode: 2017VQXPKB8V3KA

    Hier könnte Ihre Werbung stehen.

  • Ok aber irgendwie beantwortet mir das nicht komplett meiner frage?!


    Zitat

    (87833) : error 017: undefined symbol "WBB_EnableUser"
    (87867) : error 017: undefined symbol "WBB_AddUser"
    (87929) : error 017: undefined symbol "WBB_SetUserToGroup"

    Why do programmers always mix up Halloween and Christmas?
    Oct 31 == Dec 25

  • Bei mir klappt die Verbindung nicht:

    Code
    1. === WBB_Connect ===
    2. Error: Internal error. Connection bytes: <?xml version="1.0" encoding="UTF-8
    3. "?>
    4. <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.1//EN" "http://www.w3.org/TR/xhtml11/
    5. DTD/
    6. ===================
    7. Es gab einen Fehler, und WBB_Connect konnte nicht initialisiert werden.


    Der AuthKey ist: 12345 hab ich auch im Wbb so angegeben
    if(WBB_Initialize("127.0.0.1/samp/wbb", "12345")){ printf("WBB_Connect wurde erfolgreich initialisiert!");}
    else{ printf("Es gab einen Fehler, und WBB_Connect konnte nicht initialisiert werden.");}
    Plugin: SyncHTTP, sowie <wbb_connect> werden geladen.


  • Wenn bei WBB_CreateUser die EMail bereits vorhanden ist, wird der Account aber nicht erstellt oder? Beim WBB_Connect 2.0 war das nämlich noch so. Kann man das hier auch irgendwie machen?


    Zitat
    Code
    1. Ist die E-Mail Adresse vergeben gibt die Funktion "EMAIL_ALREADY_EXISTS" zurück.


    Bedeutet er erstellt sie nicht.