libcurl.so.4

  • git clone github.com/curl/curl.git./buildconf./configuremakemake test # optionalsudo make install

    -bash: git: command not found



    oder
    sudo apt install libcurl4-openssl-dev


    apt install libcurl4-openssl-dev
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    libcurl4-openssl-dev is already the newest version (7.52.1-5+deb9u9).
    0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

  • sudo apt install git

  • Ich will dir ja nicht zu nahe Treten aber deine Lösungsvorschläge sind alle für die Tonne


    Zitierter Post verweist auf ein Paket aus dem Testing Branch (Buster), Stable ist momentan Stretch. Wenn man die Suchfunktion ein wenig mehr ausreizt findet man folgendes: https://packages.debian.org/se…ame&suite=stable&arch=any


    Somit muss er nur das Paket libcurl3 installieren

    „Nicht das, was du nicht weißt, bringt dich in Schwierigkeiten, sondern dass, was du sicher zu wissen glaubst, obwohl es gar nicht wahr ist.“
    Mark Twain

    ---
    ICH BIN NUR HIER UM LEUTE ANZUSCHREIEN

  • Somit muss er nur das Paket libcurl3 installieren


    apt-get install libcurl3
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    libcurl3 is already the newest version (7.52.1-5+deb9u9).
    0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.


    hab dies bereits geht immer noch nicht habe jede webseite durchsucht aber keine lösung gefunden sitze schon seit 4 stunden und suche.

  • Dann doch aber bitte nur wenn du auch weißt was du da als Hilfe postest

    git clone github.com/curl/curl.git./buildconf./configuremakemake test # optionalsudo make install

    Hier hätte ein Prüfender Blick vor dem Abschicken gezeigt dass die Formatierung verloren gegangen ist und somit nicht mehr 1:1 kopiert werden kann


    „Nicht das, was du nicht weißt, bringt dich in Schwierigkeiten, sondern dass, was du sicher zu wissen glaubst, obwohl es gar nicht wahr ist.“
    Mark Twain

    ---
    ICH BIN NUR HIER UM LEUTE ANZUSCHREIEN

  • Das ist curl, jedoch nicht aus den Paketquellen installiert sondern aus dem Sourcecode selber kompiliert (kaum zu glauben, nicht nur SA-MP Gamemodes werden kompiliert :P)


    Ob das jedoch was bringt ist fraglich


    Wie siehts denn bei deinem SA-MP Server aus, schon mal die üblichen Diagnosetools crashdetect und Nativechecker in den Pluginsordner geschmissen?

    „Nicht das, was du nicht weißt, bringt dich in Schwierigkeiten, sondern dass, was du sicher zu wissen glaubst, obwohl es gar nicht wahr ist.“
    Mark Twain

    ---
    ICH BIN NUR HIER UM LEUTE ANZUSCHREIEN

  • //edit ohne den FS


  • Ich hab das ganze mal selber ausprobiert und einen kleinen Kniff angewandt


    LD_PRELOAD=/usr/lib/x86_64-linux-gnu/libcurl.so.4 sudo ./samp03svr


    Dabei hab ich dann folgendes erhalten:



    Heißt also dass dein gewünschtes Plugin explizit nur mit den 32bit Libraries funktioniert. Du kannst nun entscheiden ob es dir die Mühe Wert ist oder ob du dir nicht lieber ein alternatives Plugin suchst welches bessere Kompatibilität aufweist

    „Nicht das, was du nicht weißt, bringt dich in Schwierigkeiten, sondern dass, was du sicher zu wissen glaubst, obwohl es gar nicht wahr ist.“
    Mark Twain

    ---
    ICH BIN NUR HIER UM LEUTE ANZUSCHREIEN


  • Wofür brauchst du es denn?

    „Nicht das, was du nicht weißt, bringt dich in Schwierigkeiten, sondern dass, was du sicher zu wissen glaubst, obwohl es gar nicht wahr ist.“
    Mark Twain

    ---
    ICH BIN NUR HIER UM LEUTE ANZUSCHREIEN


  • forward WBB_GetUserIDFixed(playerid);
    public WBB_GetUserIDFixed(playerid) {
    new buffer[128], postData[128];
    format(postData ,sizeof postData, "&request=wbb_getId&username=%s", GetName(playerid));
    SendClientMessage(playerid, COLOR_GREEN, postData);
    //SendWbbApiRequest(postData, buffer, sizeof buffer);
    return strval(buffer);
    }
    /*
    SendWbbApiRequest(PostData[],Result[],Length)
    {
    new httpStatus = SynchronizedHTTP (WBB_CONNECT_URL, PostData , Result , Length , HTTP_GET , 5 , true);
    if(httpStatus == 200)
    {
    return true;
    }
    else
    {
    return false;
    }
    }*/

  • Beitrag von Tenchuu ()

    Dieser Beitrag wurde von seegras aus folgendem Grund gelöscht: Bitte erstmal das ganze Thema lesen, das wurde schon vorgeschlagen ().