libstdc++.so / GLIBCXX_3.4.19 nicht gefunden

  • Server
  • Linux

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

  • libstdc++.so / GLIBCXX_3.4.19 nicht gefunden

    Guten Tag liebe Leute,

    heute wollte ich meinen Server auf ein Linux System überspielen. Leider musste ich feststellen das hierbei noch ein Fehler unterläuft aufgrund von dem Mysql Plugin. Scheinbar kann er irgendetwas nicht laden. Hat einer eine Idee woran das liegen kann ? Die Serverlog gibt folgendes aus

    Brainfuck-Quellcode

    1. [15:32:02] Loaded.
    2. [15:32:02] Loading plugin: mysql.so
    3. [15:32:02] Failed (/usr/lib/i386-linux-gnu/libstdc++.so.6: version `GLIBCXX_3.4.19' not found (required by plugins/mysql.so))
    4. [15:32:02] Loaded 2 plugins.
    5. [15:32:02]
    6. [15:32:02] Filterscripts
    7. [15:32:02] ---------------
    8. [15:32:02] Loaded 0 filterscripts.
    9. [15:32:02] [debug] Run time error 19: "File or function is not found"
    10. [15:32:02] [debug] mysql_format
    11. [15:32:02] [debug] mysql_pquery
    12. [15:32:02] [debug] mysql_log
    13. [15:32:02] [debug] mysql_connect
    14. [15:32:02] [debug] mysql_errno
    15. [15:32:02] [debug] cache_get_row_count
    16. [15:32:02] [debug] Run time error 19: "File or function is not found"
    17. [15:32:02] [debug] mysql_format
    18. [15:32:02] [debug] mysql_pquery
    19. [15:32:02] [debug] mysql_log
    20. [15:32:02] [debug] mysql_connect
    21. [15:32:02] [debug] mysql_errno
    22. [15:32:02] [debug] cache_get_row_count
    23. [15:32:02] Script[gamemodes/Login_Register.amx]: Run time error 19: "File or function is not found"
    24. [15:32:02] Number of vehicle models: 0
    Alles anzeigen
  • Ergibt folgendes

    Quellcode

    1. root@vps-zap329891-1:~# dpkg --add-architecture i386
    2. root@vps-zap329891-1:~# apt-get install libstdc++6:i386
    3. Reading package lists... Done
    4. Building dependency tree
    5. Reading state information... Done
    6. libstdc++6 is already the newest version.
    7. 0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
    8. root@vps-zap329891-1:~#

    Somit schon vorhanden
  • Dann mal die ganzen Update Befehle durch und versuch mal das repository:

    Quellcode

    1. sudo add-apt-repository ppa:ubuntu-toolchain-r/test
    2. sudo apt-get update
    3. sudo apt-get upgrade
    4. sudo apt-get dist-upgrade


    Leute, lernt scripten und versucht mal lieber etwas selber zu schreiben, als es aus einem GF zu kopieren. X/
  • Da nicht, hättest du spätestens gemerkt beim Eingeben des ersten Befehls da Debian keine PPA-Repos kennt

    In deinem Fall reicht ein einfaches apt update; apt upgrade -y; apt dist-upgrade -y
    „Nicht das, was du nicht weißt, bringt dich in Schwierigkeiten, sondern dass, was du sicher zu wissen glaubst, obwohl es gar nicht wahr ist.“
    Mark Twain

    Beitrag von BreadScript ()

    Dieser Beitrag wurde vom Autor aus folgendem Grund gelöscht: unnötig bei überlegung ().
  • Bringt leider genausowenig

    seegras schrieb:

    Da nicht, hättest du spätestens gemerkt beim Eingeben des ersten Befehls da Debian keine PPA-Repos kennt

    In deinem Fall reicht ein einfaches apt update; apt upgrade -y; apt dist-upgrade -y
    Das erste hatte ich installiert problem besteht aber weiterhin. Das oder kann garnicht erst gefunden werden

    Kaliber schrieb:

    Ah sry, nicht richtig gelesen dass es um Debian geht :D

    Falls es nach den Update Befehlen nicht geht, versuch eine andere Version, wie libstdc++6-4.7-dev oder libstdc++6-7-dbg
  • Gerne


    Quellcode

    1. LIBC
    2. GLIBCXX_3.4
    3. GLIBCXX_3.4.1
    4. GLIBCXX_3.4.2
    5. GLIBCXX_3.4.3
    6. GLIBCXX_3.4.4
    7. GLIBCXX_3.4.5
    8. GLIBCXX_3.4.6
    9. GLIBCXX_3.4.7
    10. GLIBCXX_3.4.8
    11. GLIBCXX_3.4.9
    12. GLIBCXX_3.4.10
    13. GLIBCXX_3.4.11
    14. GLIBCXX_3.4.12
    15. GLIBCXX_3.4.13
    16. GLIBCXX_3.4.14
    17. GLIBCXX_3.4.15
    18. GLIBCXX_3.4.16
    19. GLIBCXX_3.4.17
    20. GLIBC_2.0
    21. GLIBC_2.3
    22. GLIBC_2.1.3
    23. GLIBC_2.2
    24. GLIBC_2.1
    25. GLIBC_2.3.2
    26. GLIBCXX_DEBUG_MESSAGE_LENGTH
    Alles anzeigen
    scheint die benannte Version nicht drin zusein
  • Ich habe gute Nachrichten. Bei mir hat es nun geklappt. Ich kann den Server nun verwenden. Es ist ein 64 Bit Betriebssystem für die R41 notwendig. Ich hatte allerdings ein 32 Bit Betriebssystem.

    Ich bedanke mich Recht herzlich bei allen Leuten die mich um diese späte Zeit unterstützt haben und wünsche euch alles Gute
  • guten Tag.

    Ich habe das gleiche Problem und auch noch keine Lösung und schon einiges ausprobiert es kommt immer:
    [13:42:33] Loading plugin: mysql.so
    [13:42:33] Failed (/usr/lib/i386-linux-gnu/libstdc++.so.6: version `GLIBCXX_3.4.19' not found (required by plugins/mysql.so))
    Das Originale SOR ( Street´s of Reallife ) seit 03.10.2009