Socket.so Problem

  • Ich habe ein Problem mit dem Plugin socket.so, der Server startet nicht ordnungsgemäß und ich weiß nicht was ich dagegen tun soll.

    Versuchte habe ich es bereits mit Ubuntu 19 und Debian 9


    Serverlog:

    ----------

    Loaded log file: "server_log.txt".

    ----------

    SA-MP Dedicated Server

    ----------------------

    v0.3.7-R2, (C)2005-2015 SA-MP Team

    [15:34:49] filterscripts = "" (string)

    [31.03.2020 - 15:34:49]

    [31.03.2020 - 15:34:49] Server Plugins

    [31.03.2020 - 15:34:49] --------------

    [31.03.2020 - 15:34:49] Loading plugin: mysql_static.so

    [31.03.2020 - 15:34:49] >> plugin.mysql: R39 successfully loaded.

    [31.03.2020 - 15:34:49] Loaded.

    [31.03.2020 - 15:34:49] Loading plugin: sscanf.so

    [31.03.2020 - 15:34:49]

    [31.03.2020 - 15:34:49] ===============================

    [31.03.2020 - 15:34:49] sscanf plugin loaded.

    [31.03.2020 - 15:34:49] Version: 2.8.1

    [31.03.2020 - 15:34:49] (c) 2012 Alex "Y_Less" Cole

    [31.03.2020 - 15:34:49] ===============================

    [31.03.2020 - 15:34:49] Loaded.

    [31.03.2020 - 15:34:49] Loading plugin: streamer.so

    [31.03.2020 - 15:34:49]

    * Streamer Plugin v2.7.5.2 by Incognito loaded *

    [31.03.2020 - 15:34:49] Loaded.

    [31.03.2020 - 15:34:49] Loading plugin: socket.so

    [31.03.2020 - 15:34:49] Failed (libcrypto.so.0.9.8: cannot open shared object file: No such file or directory)

    [31.03.2020 - 15:34:49] Loading plugin: MapAndreas.so

    [31.03.2020 - 15:34:49] Loaded.

    [31.03.2020 - 15:34:49] Loaded 4 plugins.

    [31.03.2020 - 15:34:49]

    [31.03.2020 - 15:34:49] Ban list

    [31.03.2020 - 15:34:49] --------

    [31.03.2020 - 15:34:49] Loaded: samp.ban

    [31.03.2020 - 15:34:49]

    [31.03.2020 - 15:34:49]

    [31.03.2020 - 15:34:49] Filterscripts

    [31.03.2020 - 15:34:49] ---------------

    [31.03.2020 - 15:34:49] Loaded 0 filterscripts.

    [31.03.2020 - 15:34:49] Script[gamemodes/Swl.amx]: Run time error 19: "File or function is not found"

    [31.03.2020 - 15:34:49] Number of vehicle models: 0

  • apt-get update
    apt-get install libccid libtool libglib2.0-dev libssl-dev libssl0.9.8 libpcsclite1 libpcsclite-dev libusb-dev

    Habe das selbe problem und bekomme wenn ich das mache das



    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    Package libssl0.9.8 is not available, but is referred to by another package.
    This may mean that the package is missing, has been obsoleted, or
    is only available from another source

    E: Package 'libssl0.9.8' has no installation candidate

  • Wenn man mal das github Repo anschaut, sieht man dass das plugin das letzte mal vor paar Jahren geupdated wurde, da war halt libssl0.9.8 noch aktuell.
    Ich geh mal davon aus, dass du ein neueres Ubuntu als 14.04 oder neueres Debian als 6 benutzt und da gibts das pkg nicht mehr weil veraltet.
    Du musst das manuell installieren https://askubuntu.com/a/809130 (Nicht empfohlen, hat eigentlich schon nen grund warums nicht mehr available is)

  • Wenn man mal das github Repo anschaut, sieht man dass das plugin das letzte mal vor paar Jahren geupdated wurde, da war halt libssl0.9.8 noch aktuell.
    Ich geh mal davon aus, dass du ein neueres Ubuntu als 14.04 oder neueres Debian als 6 benutzt und da gibts das pkg nicht mehr weil veraltet.
    Du musst das manuell installieren https://askubuntu.com/a/809130 (Nicht empfohlen, hat eigentlich schon nen grund warums nicht mehr available is)

    installiert wie beschrieben fehler bleibt

  • do.de - Domain-Offensive - Domains für alle und zu super Preisen