docker-compose startet nodejs app nicht

  • Moin,


    vor paar Tagen habe ich angefangen mich mit nodejs auseinander zu setzen und einen URL-Shortener gebaut - auf Basis eines Videos.

    Der funktioniert auch, der ist daher - standalone - nicht das Problem.


    Leider stimmt etwas in meiner Dockerkonfiguration nicht, weshalb ich das Projekt nicht zum Laufen bekomme.

    Vielleicht findet jemand ja den Fehler.


    Code: https://github.com/Andosius/url-shortener


    LG

    • Offizieller Beitrag
    • Hilfreich

    Was oder wer meckert denn? Docker selbst oder die Apps innerhalb des Containers?


    13423


    „Nicht das, was du nicht weißt, bringt dich in Schwierigkeiten, sondern dass, was du sicher zu wissen glaubst, obwohl es gar nicht wahr ist.“
    Mark Twain

    ---
    ICH BIN NUR HIER UM LEUTE ANZUSCHREIEN

  • Sobald ich den Container erstmal baue und anschließend mit docker-compose up starte, loopt der nodejs Container permanent im Neustart rum.

    D.h der Status bleibt restarting. Egal, wie lange ich warte.



    Edit:

    Okay, ich habe den Fehler gefunden. Das wait-Script hat den Fehler verursacht. Einfach den Command mit npm start ersetzt und es läuft so schön wie noch nie.

    Manchmal ist einfach einfach besser. :)


    Habe mir nochmal Zeit genommen und den es mal nicht daemonised gestartet.. was man da nicht so alles für schöne outputs kriegt xD

    2 Mal editiert, zuletzt von Andosius ()

    • Offizieller Beitrag

    Immerhin bekommst du ja eine Logausgabe, ich frage mich nur warum offenbar chmod hier rumzickt und bspw && nicht verarbeiten kann

  • ich frage mich nur warum offenbar chmod hier rumzickt und bspw && nicht verarbeiten kann

    Da habe ich auch noch ein wenig rumprobiert und keine schöne Lösung gefunden. Ich belasse es jetzt einfach bei npm start und das sollte seinen Zweck erfüllen.

    Die MongoDB sollte auf jeden Fall schnell genug starten, sodass die App nicht crasht. Solange das gegeben ist, bin ich da relativ entspannt. xD

    • Offizieller Beitrag

    Ich habe noch mal ein wenig rumprobiert und bin zu dem Ergebnis gekommen dass es mit dieser wait-for.sh zusammenhängen muss, der Sinn hinter diesem Script erschließt sich mir noch nicht so ganz. Kommt diese Datei aus dem node:alpine Image?


    Alternativ könntest du das Pferd auch anders herum aufzäumen und dein Image so beginnen


    Docker
    FROM alpine
    RUN apk add --update nodejs npm

    Macht die Sache auch noch gleich etwas schlanker


    raw


    13423


    „Nicht das, was du nicht weißt, bringt dich in Schwierigkeiten, sondern dass, was du sicher zu wissen glaubst, obwohl es gar nicht wahr ist.“
    Mark Twain

    ---
    ICH BIN NUR HIER UM LEUTE ANZUSCHREIEN