Problem beim SSL (Apache-Webserver)

Aus gegebenem Anlass: Sichert eure Backupcodes wenn ihr die Zwei-Faktor-Authentifizierung aktiviert habt!

Infos dazu findet ihr nochmal hier

Nimm am Dezember Gewinnspiel von breadfish.de teil und gewinne u.A. eine Playstation 5 oder eine Apple Watch. Klicke hier
  • Moin,


    mein Apache2.4 Webserver hat die Erdbeer Woche, konkret startet dieser nicht. Das liegt definitiv am SSL.


    Code
    1. Feb 28 01:29:45 patrick systemd[1]: Starting The Apache HTTP Server...
    2. Feb 28 01:29:45 patrick apachectl[24954]: (98)Address already in use: AH00072: make_sock: could not bind to address {MEINE_IP}:443
    3. Feb 28 01:29:45 patrick apachectl[24954]: no listening sockets available, shutting down
    4. Feb 28 01:29:45 patrick apachectl[24954]: AH00015: Unable to open logs
    5. Feb 28 01:29:45 patrick apachectl[24954]: Action 'start' failed.
    6. Feb 28 01:29:45 patrick apachectl[24954]: The Apache error log may have more information.
    7. Feb 28 01:29:45 patrick systemd[1]: apache2.service: Control process exited, code=exited, status=1/FAILURE
    8. Feb 28 01:29:45 patrick systemd[1]: apache2.service: Failed with result 'exit-code'.
    9. Feb 28 01:29:45 patrick systemd[1]: Failed to start The Apache HTTP Server.


    Sofern ich in /etc/apache2/ports.conf die Listen 443 auskommentiere, lässt sich Apache2 starten.



    Das ist aber jedoch nicht Sinn der Sache, beabsichtige Lets Encrypt zu verwenden, mir wird aber kein Zertifikat ausgestellt, wenn doch, das würde nicht funktionieren. Symptome zu bekämpfen ist der falsche weg, den Fehler muss man beheben.


    Hat jemand hier Ahnung, Ideen, oder hatte mal das selbe Problem?

    Im übrigen ich verwende Froxlor, das erste mal jedoch unter Debian 10 (Debian Buster).


    Vielen Dank im vorraus! :)

    Wer PALWAL-Sternchen vergibt, bekommt aus Prinzip ein Like 😏


    palwal Donald Trump ist einer der besten Präsidenten welche die USA je hatte, meine Meinung.

  • Kannst du mal schauen was

    lsof -i :443

    ausgibt?


    //oder kommentierst du immer beide Listen ein und aus? Es darf nämlich nur ein mal Listen 443 laufen

    Einmal editiert, zuletzt von Syno ()

  • Wenn die Listen 443 in /etc/ports.conf auskommentiert sind


    Code
    1. apache2 15476 www-data 5u IPv4 211832 0t0 TCP ip{IP-IN-BINDE-STRICHEN}.hostrado.net:https (LISTEN)
    2. apache2 15477 www-data 5u IPv4 211832 0t0 TCP ip{IP-IN-BINDE-STRICHEN}.hostrado.net:https (LISTEN)
    3. apache2 15478 www-data 5u IPv4 211832 0t0 TCP ip{IP-IN-BINDE-STRICHEN}.hostrado.net:https (LISTEN)
    4. apache2 15479 www-data 5u IPv4 211832 0t0 TCP ip{IP-IN-BINDE-STRICHEN}.hostrado.net:https (LISTEN)
    5. apache2 15480 www-data 5u IPv4 211832 0t0 TCP ip{IP-IN-BINDE-STRICHEN}.hostrado.net:https (LISTEN)
    6. apache2 27260 root 5u IPv4 211832 0t0 TCP ip{IP-IN-BINDE-STRICHEN}.hostrado.net:https (LISTEN)


    Sofern nicht, kackt der Apache ab und wird bei lsof -i :443 nichts ,ehr ausgeben.

    Wer PALWAL-Sternchen vergibt, bekommt aus Prinzip ein Like 😏


    palwal Donald Trump ist einer der besten Präsidenten welche die USA je hatte, meine Meinung.

  • Du arbeitest vermutlich nach einer Anleitung, da ich vorher noch nie gesehen habe dass jemand diese ports.conf bearbeitet hat


    Wozu soll diese Konfigurationsdatei denn gut sein? Was passiert bei einer frischen Installation von Apache mit unverbastelten Konfigurationsdateien


    13423


    „Nicht das, was du nicht weißt, bringt dich in Schwierigkeiten, sondern dass, was du sicher zu wissen glaubst, obwohl es gar nicht wahr ist.“
    Mark Twain

    ---
    ICH BIN NUR HIER UM LEUTE ANZUSCHREIEN

  • Da gab es keine Probleme. Vllt wurde durch Froxlor eine config falsch geschrieben.


    Ja die Idee mit den Listen auskommentieren stammt von Dr. Google. Will aber SSL verwenden, deshalb hoffe ich das du oder jmd anderes bei diesem Problem helfen kann.

    Wer PALWAL-Sternchen vergibt, bekommt aus Prinzip ein Like 😏


    palwal Donald Trump ist einer der besten Präsidenten welche die USA je hatte, meine Meinung.

  • do.de - Domain-Offensive - Domains für alle und zu super Preisen
  • Certbot problemlos installiert, SSL Zertifikat lässt sich auch installieren. Allerdings ohne HTTPS Weiterleitung. Stelle ich die SSL Weiterleitung bei der dazugehörigen Domain in Froxlor ein, funktioniert das SSL Zertifikat nicht, Firefox meldet SSL_ERROR_RX_RECORD_TOO_LONG


    Die vHost Einstelungen in site-enabled sind auch negativ, sprich leer.

    Wer PALWAL-Sternchen vergibt, bekommt aus Prinzip ein Like 😏


    palwal Donald Trump ist einer der besten Präsidenten welche die USA je hatte, meine Meinung.